Laman

Blocking TCP Packet

0 Comments

Script berikut dibawah ini adalah untuk mem-block trafik TCP, dengan cara menutup port-nya. Tentu saja sobat bisa menambahkan port apa saja yang hendak atau ingin ditutup, misalnyaport port yang biasa dilalui oleh virus dan sebagainya.

Buka Winbox, kemudian terminal, dan ketikkan script berikut ini di terminal sobat.


/ip firewall filter
add chain=tcp protocol=tcp dst-port=67-69 action=drop comment="Bloking TCP Packet" disabled=no
add chain=tcp protocol=tcp dst-port=111 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=119 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=135 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=137-139 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=445 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=2049 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=3133 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=12345-12346 action=drop comment="" disabled=no
add chain=tcp protocol=tcp dst-port=20034 action=drop comment="" disabled=no

Selamat berkreatifitas.

Undergoing MyBlogLog Verification

Import Blog ke Note nya Facebook

0 Comments

Bagi pengguna Facebook tentunya sudah tidak asing lagi melihat gambar di samping ini, yang mana gambar ini adalah tab (kolom) menu catatan milik empunya ID Facebook yang bersangkutan. Para Blogger yang memiliki akun Facebook bisa meng-import artikel nya ke note Facebook, tentunya teman sudah banyak yang tahu, tulisan ini hanya sekedar catatan kecil untuk back-up otak jikalau kita sedang lupa :)

Notes Facebook akan auto update jika ada tulisan baru yang ada di blogspot kita tanpa harus manual menyalinnya ke Notes Facebook, bagaimana caranya? berikut step by step nya :

1. Login akun Facebook sobat
2. Buka tab profil
3. Tekan tombol + di bagian tab menu dan pilih "notes"


4. Pilih tombol "edit import setting"


Jika sobat tidak melihat tombol itu, cobalah untuk menulis note sembarangan (nanti bisa dihapus) untuk menampilkan tombol itu.

5. Pada kolom "web url" masukkan link blog sobat


6. Check tanda centang dan tekan tombol "start import"

7. Pilh "confirm" untuk meyakinkan bahwa url yang anda masukkan adalah benar.

Jika ada postingan yang baru di blog sobat maka notes ini akan auto update di wall sobat dan di kolom notes.

selamat mencoba.

Pengkabelan UTP (CAT5 dan CAT5e)

0 Comments


Pertama mungkin kita akan sedikit mengulas apa sih kabel UTP itu? Kabel UTP (unshielded twisted pair) biasa digunakan untuk menghubungkan koneksi/jaringan antar komputer yang terhubung dalam bentuk lokalan, connector yang dipakai adalah type RJ-45.

Pemberian kategori type merupakan kategori spesifikasi untuk masing-masing kabel tembaga dan juga untuk jack. Masing-masing merupakan seri revisi atas kualitas kabel, kualitas pembungkusan kabel (isolator) dan juga untuk kualitas “belitan” (twist) masing-masing pasang kabel. Selain itu juga untuk menentukan besaran frekuensi yang bisa lewat pada sarana kabel tersebut, dan juga kualitas isolator sehingga bisa mengurangi efek induksi antar kabel (noise bisa ditekan sedemikian rupa). Perlu diperhatikan juga, spesifikasi antara CAT5 dan CAT5e (enchanced) mempunyai standar industri yang sama, namun pada CAT5e sudah dilengkapi dengan insulator untuk mengurangi efek induksi atau electromagnetic interference. Kabel CAT5e bisa digunakan untuk menghubungkan network hingga kecepatan 1Gbps.

Untuk penggunaan koneksi komputer, dikenal 2 buah tipe penyambungan kabel UTP ini, yaitu straigh cable dan crossover cable. Fungsi masing-masing jenis koneksi ini berbeda, straight cable digunakan untuk menghubungkan client ke hub/router, sedangkan crossover cable digunakan untu menghubungkan client ke client atau dalam kasus tertentu digunakan untuk menghubungkan hub ke hub.


A. Straight Cable

Untuk menghubungkan dua connector straight cable, antara ujung kabel (PIN A) dan ujung kabel yang satunya (PIN B) harus sama warna kabelnya. Untuk standarisasi warna kabel tidak menjadi ukuran, hanya saja pada contoh ini kita menggunakan warna seperti gambar dibawah ini:


Yang mana warna kabel pada PIN A (Connector A) :
1. Putih Orange
2. Orange
3. Putih Hijau
4. Biru
5. Putih Biru
6. Hijau
7. Putih Coklat
8. Coklat

Pada PIN B (Connector B) warna setiap ujung-ujung kabel kecil nya tetap sama susunannya dengan warna kabel pada Connector A (PIN A).


B. Crossover Cable

Crossover Cable biasa digunakan untuk menghubungkan antara dua komputer (peer to peer) atau bisa juga digunakan untuk menghubungkan antara hub ke hub. Untuk membentuk jenis kabel ini ada 4 kabel yang berpindah posisi sehingga membentuk cross (silang), jika kita pada connector A menggunakan warna seperti contoh diatas (straight cable) maka warna yang disilang tersebut pada Connector B adalah kabel 1,2,3, dan 6 :

Warna kabel pada PIN A (Connector A) :
1. Putih Orange
2. Orange
3. Putih Hijau
4. Biru
5. Putih Biru
6. Hijau
7. Putih Coklat
8. Coklat

note : warna kabel pada connector A tetap/tidak berubah.

Warna kabel pada PIN B (Connector B) :
1. Putih Hijau
2. Hijau
3. Putih Orange
4. Biru
5. Putih Biru
6. Orange
7. Putih Coklat
8. Coklat

Untuk pastinya lihat warna pada gambar dibawah ini :


Semoga membantu.
Sumber : www.littlewhitedog.com - www.ilmukomputer.com

Source VB Aplikasi "WinColor"

0 Comments

Pada postingan saya yang terdahulu "Tool Pengganti Warna Windows" telah dijelaskan kegunaannya, yaitu sebagai tool untuk mengganti warna window yang mana tool ini mengambil nilai value yang berada di dalam registry pc.

Postingan berikut ini adalah source dari tool itu sendiri, semoga bermanfaat bagi teman. Silahkan modifikasi dengan imajinasi teman sendiri. Komponent yang harus disiapkan adalah "TextBox" sebanyak 30 biji dan satu buah CommandButton. Berikut adalah listing programnya :

Sub check_Text1()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ActiveBorder = codetan.regread("HKCU\Control Panel\Colors\ActiveBorder")
Text1.Text = ActiveBorder
End Sub

Sub check_Text2()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ActiveTitle = codetan.regread("HKCU\Control Panel\Colors\ActiveTitle")
Text2.Text = ActiveTitle
End Sub

Sub check_Text3()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
AppWorkSpace = codetan.regread("HKCU\Control Panel\Colors\AppWorkSpace")
Text3.Text = AppWorkSpace
End Sub

Sub check_Text4()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Background = codetan.regread("HKCU\Control Panel\Colors\Background")
Text4.Text = Background
End Sub

Sub check_Text5()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ButtonAlternateFace = codetan.regread("HKCU\Control Panel\Colors\ButtonAlternateFace")
Text5.Text = ButtonAlternateFace
End Sub

Sub check_Text6()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ButtonDkShadow = codetan.regread("HKCU\Control Panel\Colors\ButtonDkShadow")
Text6.Text = ButtonDkShadow
End Sub

Sub check_Text7()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ButtonFace = codetan.regread("HKCU\Control Panel\Colors\ButtonFace")
Text7.Text = ButtonFace
End Sub

Sub check_Text8()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ButtonHilight = codetan.regread("HKCU\Control Panel\Colors\ButtonHilight")
Text8.Text = ButtonHilight
End Sub

Sub check_Text9()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Buttonlight = codetan.regread("HKCU\Control Panel\Colors\Buttonlight")
Text9.Text = Buttonlight
End Sub

Sub check_Text10()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ButtonShadow = codetan.regread("HKCU\Control Panel\Colors\ButtonShadow")
Text10.Text = ButtonShadow
End Sub

Sub check_Text11()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
ButtonText = codetan.regread("HKCU\Control Panel\Colors\ButtonText")
Text11.Text = ButtonText
End Sub

Sub check_Text12()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
GradientActiveTitle = codetan.regread("HKCU\Control Panel\Colors\GradientActiveTitle")
Text12.Text = GradientActiveTitle
End Sub

Sub check_Text13()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
GradientInActiveTitle = codetan.regread("HKCU\Control Panel\Colors\GradientInActiveTitle")
Text13.Text = GradientInActiveTitle
End Sub

Sub check_Text14()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
GrayText = codetan.regread("HKCU\Control Panel\Colors\GrayText")
Text14.Text = GrayText
End Sub

Sub check_Text15()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
HotTrackingColor = codetan.regread("HKCU\Control Panel\Colors\HotTrackingColor")
Text15.Text = HotTrackingColor
End Sub

Sub check_Text16()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Hilight = codetan.regread("HKCU\Control Panel\Colors\Hilight")
Text16.Text = Hilight
End Sub

Sub check_Text17()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
HilightText = codetan.regread("HKCU\Control Panel\Colors\HilightText")
Text17.Text = HilightText
End Sub

Sub check_Text18()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
InactiveBorder = codetan.regread("HKCU\Control Panel\Colors\InactiveBorder")
Text18.Text = InactiveBorder
End Sub

Sub check_Text19()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
InactiveTitle = codetan.regread("HKCU\Control Panel\Colors\InactiveTitle")
Text19.Text = InactiveTitle
End Sub

Sub check_Text20()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
InactiveTitleText = codetan.regread("HKCU\Control Panel\Colors\InactiveTitleText")
Text20.Text = InactiveTitleText
End Sub

Sub check_Text21()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
InfoText = codetan.regread("HKCU\Control Panel\Colors\InfoText")
Text21.Text = InfoText
End Sub

Sub check_Text22()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
InfoWindow = codetan.regread("HKCU\Control Panel\Colors\InfoWindow")
Text22.Text = InfoWindow
End Sub

Sub check_Text23()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Menu = codetan.regread("HKCU\Control Panel\Colors\Menu")
Text23.Text = Menu
End Sub

Sub check_Text24()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
MenuBar = codetan.regread("HKCU\Control Panel\Colors\MenuBar")
Text24.Text = MenuBar
End Sub

Sub check_Text25()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
MenuHilight = codetan.regread("HKCU\Control Panel\Colors\MenuHilight")
Text25.Text = MenuHilight
End Sub

Sub check_Text26()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
MenuText = codetan.regread("HKCU\Control Panel\Colors\MenuText")
Text26.Text = MenuText
End Sub

Sub check_Text27()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Scrollbar = codetan.regread("HKCU\Control Panel\Colors\Scrollbar")
Text27.Text = Scrollbar
End Sub

Sub check_Text28()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
TitleText = codetan.regread("HKCU\Control Panel\Colors\TitleText")
Text28.Text = TitleText
End Sub

Sub check_Text29()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Window = codetan.regread("HKCU\Control Panel\Colors\Window")
Text29.Text = Window
End Sub

Sub check_Text30()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
WindowFrame = codetan.regread("HKCU\Control Panel\Colors\WindowFrame")
Text30.Text = WindowFrame
End Sub

Sub check_Text31()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
WindowText = codetan.regread("HKCU\Control Panel\Colors\WindowText")
Text31.Text = WindowText
End Sub

Private Sub Command1_Click()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
codetan.RegWrite "HKCU\Control Panel\Colors\ActiveBorder", Text1, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ActiveTitle", Text2, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\AppWorkSpace", Text3, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\Background", Text4, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ButtonAlternateFace", Text5, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ButtonDkShadow", Text6, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ButtonFace", Text7, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ButtonHilight", Text8, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\Buttonlight", Text9, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ButtonShadow", Text10, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\ButtonText", Text11, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\GradientActiveTitle", Text12, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\GradientInActiveTitle", Text13, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\GrayText", Text14, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\HotTrackingColor", Text15, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\Hilight", Text16, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\HilightText", Text17, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\InactiveBorder", Text18, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\InactiveTitle", Text19, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\InactiveTitleText", Text20, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\InfoText", Text21, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\InfoWindow", Text22, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\Menu", Text23, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\MenuBar", Text24, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\MenuHilight", Text25, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\MenuText", Text26, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\Scrollbar", Text27, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\TitleText", Text28, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\Window", Text29, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\WindowFrame", Text30, "REG_SZ"
codetan.RegWrite "HKCU\Control Panel\Colors\WindowText", Text31, "REG_SZ"
End Sub

Private Sub Form_Load()
header
check_Text1
check_Text2
check_Text3
check_Text4
check_Text5
check_Text6
check_Text7
check_Text8
check_Text9
check_Text10
check_Text11
check_Text12
check_Text13
check_Text14
check_Text15
check_Text16
check_Text17
check_Text18
check_Text19
check_Text20
check_Text21
check_Text22
check_Text23
check_Text24
check_Text25
check_Text26
check_Text27
check_Text28
check_Text29
check_Text30
check_Text31
End Sub

Sub header()
On Error Resume Next
Me.Caption = " • " & App.Title & " - " & App.CompanyName
End Sub
Untuk hasil yang telah jadi silahkan teman lihat di link ini. Selamat berkarya.

Tool Pengganti Warna Windows

0 Comments

Tool ini membantu kita untuk mengedit tampilan warna dari window. Bagi teman yang merasa cepat jenuh dengan warna window, mungkin dengan tool ini bisa sedikit membantu. Format warna yang digunakan adalah RGB, gunakan Photoshop untuk menemukan formula warna yang cocok untuk teman dapatkan code nya.

Isikan setiap kolom yang hendak diganti warna nya, sebaiknya teman memback-up terlebih dahulu code warna semula dengan cara mencatat isian pada valuenya, karena dikhawatirkan setelah warna yang diganti tidak sesuai dengan selera teman.

Lihat gambar dibawah ini untuk tampilan dari aplikasi pengganti warna window, jika teman tertarik silahkan download disini


Value yang ada saat ini berada di dalam kolom-kolom isian tersebut, merupakan value angka format dari warna yang dipakai oleh window teman itu sendiri. Aplikasi ini mengambil nilai value dari dalam registry teman untuk value warnanya.

Selamat mencoba

Source Aplikasi (Block Aplikasi Windows)

0 Comments

Pada postingan sebelumnya saya memberikan sebuah aplikasi/tools yang bisa digunakan untuk memblock file agar tidak bisa dijalankan, selama nama file tersebut tidak diganti (rename). Tools tersebut bisa digunakan dalam hal memproteksi file system yang berada di pc teman, misalkan regedit.exe, taskmanager, dan lain sebagainya. Memang tidak terproteksi 100% tetapi setidaknya ada sedikit pengamanan bagi pc kita terhadap user yang jahil.

berikut ini akan saya sampaikan source dari aplikasi yang saya posting sebelumnya, menggunakan VB6. Adapun komponen yang diperlukan adalah sebagai berikut :

  1. check1 (type : CheckBox)
  2. text1 (type : TextBox)
  3. text2 (type : TextBox)
  4. text3 (type : TextBox)
  5. text4 (type : TextBox)
  6. text5 (type : TextBox)
  7. text6 (type : TextBox)
  8. text7 (type : TextBox)
  9. text8 (type : TextBox)
  10. text9 (type : TextBox)
  11. text10 (type : TextBox)
  12. command1 (type : CommandButton)
  13. command2 (type : CommandButton)
Source ini merupakan kerangka, ada baiknya jika teman memolesnya menjadi suatu aplikasi yang tampil indah. Berikur isi source nya :
Private Sub Form_Load()
Me.Caption = " • " & App.Title & " - " & App.CompanyName
periksa_DisallowRun
baca_DisallowRun
End Sub
Private Sub Check1_Click()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
If Check1.Value = "1" Then
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun", 1, "REG_DWORD"
End If
If Check1.Value = "0" Then
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun", 0, "REG_DWORD"
End If
periksa_DisallowRun2
End Sub
Sub periksa_DisallowRun2()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
DisallowRun = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun")
If DisallowRun = 1 Then
Text1.Enabled = True
Text2.Enabled = True
Text3.Enabled = True
Text4.Enabled = True
Text5.Enabled = True
Text6.Enabled = True
Text7.Enabled = True
Text8.Enabled = True
Text9.Enabled = True
Text10.Enabled = True
Command1.Enabled = True
Command2.Enabled = True
Else
Text1.Enabled = False
Text2.Enabled = False
Text3.Enabled = False
Text4.Enabled = False
Text5.Enabled = False
Text6.Enabled = False
Text7.Enabled = False
Text8.Enabled = False
Text9.Enabled = False
Text10.Enabled = False
Command1.Enabled = False
Command2.Enabled = False
End If
End Sub
Sub periksa_DisallowRun()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
DisallowRun = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun")
If DisallowRun = 1 Then
Check1.Value = "1"
Text1.Enabled = True
Text2.Enabled = True
Text3.Enabled = True
Text4.Enabled = True
Text5.Enabled = True
Text6.Enabled = True
Text7.Enabled = True
Text8.Enabled = True
Text9.Enabled = True
Text10.Enabled = True
Command1.Enabled = True
Command2.Enabled = True
Else
Check1.Value = "0"
Text1.Enabled = False
Text2.Enabled = False
Text3.Enabled = False
Text4.Enabled = False
Text5.Enabled = False
Text6.Enabled = False
Text7.Enabled = False
Text8.Enabled = False
Text9.Enabled = False
Text10.Enabled = False
Command1.Enabled = False
Command2.Enabled = False
End If
End Sub
Sub baca_DisallowRun()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
DisallowRun0 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\0")
DisallowRun1 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\1")
DisallowRun2 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\2")
DisallowRun3 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\3")
DisallowRun4 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\4")
DisallowRun5 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\5")
DisallowRun6 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\6")
DisallowRun7 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\7")
DisallowRun8 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\8")
DisallowRun9 = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\9")
Text1.Text = DisallowRun0
Text2.Text = DisallowRun1
Text3.Text = DisallowRun2
Text4.Text = DisallowRun3
Text5.Text = DisallowRun4
Text6.Text = DisallowRun5
Text7.Text = DisallowRun6
Text8.Text = DisallowRun7
Text9.Text = DisallowRun8
Text10.Text = DisallowRun9
End Sub

Private Sub Command1_Click()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
Text1.Text = ""
Text2.Text = ""
Text3.Text = ""
Text4.Text = ""
Text5.Text = ""
Text6.Text = ""
Text7.Text = ""
Text8.Text = ""
Text9.Text = ""
Text10.Text = ""
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\0", Text1, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\1", Text2, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\2", Text3, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\3", Text4, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\4", Text5, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\5", Text6, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\6", Text7, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\7", Text8, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\8", Text9, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\9", Text10, "REG_SZ"
End Sub

Private Sub Command2_Click()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\0", Text1, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\1", Text2, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\2", Text3, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\3", Text4, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\4", Text5, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\5", Text6, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\6", Text7, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\7", Text8, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\8", Text9, "REG_SZ"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun\9", Text10, "REG_SZ"
End Sub
Aplikasi yang dimaksud dalam tampilan setelah didandani :


Aplikasi ini bisa teman download (dalam bentuk exe) di sini.

Selamat mencoba, dan selalu salam codet dari palembang untuk nusantara.

Block Aplikasi (Windows)

0 Comments

Aplikasi pada windows bisa di-block dengan menggunakan registry, mungkin teman-teman telah banyak yang mengetahuinya. Namun disini saya akan mempermudahnya dengan melakukan scripting dan menjadikannya sebuah aplikasi. Jadi teman-teman tidak lagi harus bersusah payah untuk membuka badan registry, mencari letak kode, dan mengedit nya, teman cukup membuka aplikasi ini dan mengentry nama aplikasi yang hendak di block tersebut.

Aplikasi yang dimaksud dapat di download di sini


Centang "Aktifkan Block Aplikasi" jika teman hendak input atau mengaktifkannya, dan sebaliknya. Pada kondisi ini kita misalkan hendak memblock registry.exe, maka aktifkan block aplikasi dengan mencentang nya, dan masukkan entry "registry.exe" ke dalam field kosong. Tekan tombol Save, dan lakukan log-off atau restart pc teman untuk mendapatkan hasilnya.


Setelah Restart, teman akan mendapat kan sebuah pop-up pemberitahuan ketika menjalankan file tersebut.

Aplikasi ini tidak 100% bisa memprotek file teman, dengan me-rename nama file tersebut kita telah bisa mengelabui aplikasi ini untuk membuka nya, tetapi setidaknya kita telah peduli terhadap keamanan system kita sendiri dengan mem-block file-file penting di system os kita

Selamat mencoba. Salam matcodet.

Source VB Pengunci dan Pembuka Registry

0 Comments

Component yang dibutuhkan :
  1. Command1 dan Command2 (button)
  2. Option1 dan Option2 (Option)
Berikut ini isi source codenya :

Private Sub Command1_Click()
On Error Resume Next
Shell "regedit.exe", vbNormalFocus
End Sub

Private Sub Command2_Click()
Unload Me
End Sub

Private Sub Form_Load()
Me.Caption = " • " & App.Title & " - " & App.LegalCopyright
cek_DisableRegistryTools
End Sub
Sub cek_DisableRegistryTools()
On Error Resume Next
Set codetan = CreateObject("WScript.Shell")
codetx = codetan.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools")
If codetx = 1 Then
Option1.Value = "1"
Else
Option2.Value = "1"
End If
End Sub

Private Sub Option1_Click()
Set codetan = CreateObject("WScript.Shell")
If Option1.Value = "1" Then
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools", 1, "REG_DWORD"
codetan.RegWrite "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools", 1, "REG_DWORD"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegedit", 1, "REG_DWORD"
codetan.RegWrite "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegedit", 1, "REG_DWORD"
End If
End Sub
Private Sub Option2_Click()
Set codetan = CreateObject("WScript.Shell")
If Option2.Value = "1" Then
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools", 0, "REG_DWORD"
codetan.RegWrite "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools", 0, "REG_DWORD"
codetan.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegedit", 0, "REG_DWORD"
codetan.RegWrite "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegedit", 0, "REG_DWORD"
End If
End Sub


Untuk hasil yang telah jadi dpt dilihat dilink berikut ini. Dengan sedikit penambahan aksesoris biar kelihatan cantik.

Selamat mencoba, salam matcodet.

Pembuka / Pengunci Registry

0 Comments

Kebanyakan dari warnet/Perusahaan/Individu yang tersebar di seluruh Pulau-Pulau di Indonesia telah mengunci registry nya dengan alasan beraneka macam, alasan terbesar adalah demi keamanan system. Keamanan system bukan terletak pada registrynya tetapi pada sumber daya pengelola systemnya.

Banyak pengunjung yang mengakses google, masih mempertanyakan bagaimana cara membuka registry yang terkunci atau bagaimana cara mengunci registry itu sendiri. Banyak cara untuk membuka dan mengunci registry, namun disini saya akan mempermudahnya dengan bantuan aplikasi yang telah saya buat sendiri melalui VB. Mudah-mudahan aplikasi bisa membantu untuk mengunci dan membuka registry.

Jika pada suatu komputer ditemukan pop-up seperti gambar berikut dibawah ini ketika mengakses regedit.exe :


Maka dapat dipastikan registry yang hendak anda buka telah dikunci/terkunci, kita bisa membukanya dengan aplikasi "registry.exe" yang saya buat ini. Download dan jalankan aplikasi tersebut.


Klik option "Un-Lock Registry" untuk membukanya dan klik option "Lock Registry" untuk menguncinya. Klik tombol "Call Registry" untuk memanggil "regedit.exe". Jika regedit.exe tetap tidak bisa dibuka, berarti masih ada protect nya, tetapi setidaknya dengan aplikasi ini, sedikit banyak kita telah bisa mengunci dan membuka registry itu sendiri. Untuk source codenya bisa dilihat di halaman berikut ini.

Selamat mencoba, salam matcodet.

BERITA PDRD